Table of Contents
Overview
SIS-Specific Merge Error Guides
FAQs
Troubleshooting Merge Errors
Related Articles
Overview
Student Information System (SIS) platforms have certain requirements that must be met in order for data to be accepted during a merge. If those requirements are not met, a merge error can occur.
This article captures general FAQs and troubleshooting issues that can occur regardless of SIS but also links out to common merge error guides that are SIS-specific.
For a general overview of managing merge errors, go here.
SIS-Specific Merge Error Guides
An SIS-specific merge error guide for Jenzabar EX is attached to the bottom of this article.
You can find additional SIS-specific merge error guides at the following links:
These guides walk you through common merge errors as well as how to resolve and prevent them.
If your SIS isn’t included, reach out to your Customer Success contact for guidance.
FAQs
How can I prevent merge errors from happening in the first place?
Do relationship integration errors appear in the integration dashboard?
How can I prevent merge errors from happening in the first place?
Many merge errors can be prevented by creating and/or enabling section rules. You can learn more about section rules here.
Do relationship integration errors appear in the integration dashboard?
Relationship integration errors will not appear in the Integration Dashboard. Relationship integration errors will show only in the relationship modal, which is accessible in two places: the Relationship page and the section editing modal.
Relationship Page: Academic Scheduling > Relationships.
Section Editing Modal: Academic Scheduling > Section Dashboard > Click Section) > Relationships.
You can learn more about relationships here.
Troubleshooting Merge Errors
Troubleshooting Overview
Custom Field Wiped During Nightly Merge
Changes in SIS Don't Appear in Coursedog
Could Not Fetch Data from SIS
Failing with [#] Errors Sending Back to SIS
404 Not Found, 406 Not Acceptable, 502 Bad Gateway and 504 Gateway Time Out
Missing Attribute Mappings
No Coursedog or SIS Data Found
Numeric or Value Error for Section Merges
Code Field Not Updating
Halted: Change Threshold Exceeded
Troubleshooting Overview
The below steps provide a high-level overview of reviewing and resolving merge errors.
Step 1:
Locate the report that contains errors.
If you aren’t sure, you can reference the date of the merge notification email you received that noted errors.
Step 2: Click “View Report Details”.
Step 3: Expand the section containing the errors by clicking the toggle next to any steps that say “Unable to sync some changes”.
Step 4:
Review the errors section of the report to find a reason for the failure.
You can then decide if the scheduler was doing something incorrectly in Coursedog such as deleting meetings and leaving the assigned instructor still configured or if there are errors that require the Coursedog Customer Success team to assist.
Step 5:
Using the merge error as your guide, edit the section.
Access the section editing modal at Academic Scheduling > Section Dashboard > (Click Section).
Custom Field Wiped During Nightly Merge
Problem Overview
A custom field is being wiped in every nightly merge.
Explanation
This can happen if a custom field hasn’t been added as a field-specific exception in your merge settings, with the source of truth defined as “Always Coursedog”.
Solution Overview
Video
Step-By-Step
Step 1: Navigate to Admin Dashboard > Merge Settings > Type-Specific Settings > (Select Entity) > Field-Specific Exceptions.
Step 2: If you don’t see this field in the “Source of truth” dropdown, scroll to the very bottom and select “Add Custom Exception”.
Step 3: In the “Label” field, input the name you’re using for this Custom Field.
Step 4:
In the “Path” field, input “customFields.” followed by the Question Id for this Custom Field, e.g. customFields.liwqc.
You can find the Question ID by opening the template where this field has been added and clicking into the field to see its question settings.
Step 5: Click “Save” for the Custom Field Exception.
Step 6: Ensure “Source of Truth” is “Always Coursedog”.
Step 7: Click “Save” again at the top of the Merge Settings page before navigating away.
Changes in SIS Don't Appear in Coursedog
Problem Overview
Changes you made to data in your SIS aren’t appearing in Coursedog.
Solution Overview
When making changes to data in the SIS, those changes are typically not reflected in Coursedog immediately and will generally take up to 24 hours to go through.
If you have recently made a change to data in the SIS and that data appears to be missing, please ensure you have allowed the appropriate amount of time for the changes to be pushed through.
Could Not Fetch Data from SIS
Problem Overview
This typically refers to a connection issue that may be related to the SIS, DataPort, or with a Coursedog data partner.
Solution Overview
Any time this specific message appears following a nightly integration, best practice is to reach out to Coursedog Support.
Failing with [#] Errors Sending Back to SIS
Problem Overview
This means that an update failed to successfully sync to the SIS.
Solution Overview
This is just a section title in the report that lets you know how many errors occurred; you’ll need to review individual errors within the report to solve each one.
404 Not Found, 406 Not Acceptable, 502 Bad Gateway and 504 Gateway Time Out
Problem Overview
If these errors are encountered, they will appear in the merge report and likely result in the complete failure of a merge.
Solution Overview
The suggested solution depends on a few factors; review each of the below to determine which course of action is best for you.
If You Experience This During a Real-Time Merge
Try the real-time merge again to see if the real-time merge succeeds or continues to fail.
If You Experience This During the Nightly Merge
If real-time merges are enabled, verify whether they are currently succeeding. If they are, wait for the next nightly merge to complete. If the nightly merge fails again, check with your school IT department to validate whether your SIS system is available during the period in which the nightly merges run. The SIS system may be unavailable for a period of time each night to facilitate IT maintenance, reporting, and other tasks. If this is the case, contact Coursedog support to discuss resolution steps.
If Real-Time Merges are Currently Failing in Addition to the Nightly Merge
Contact Coursedog support, N2N support, or your internal IT support to verify the state of the integration gateway (if present) and restart if necessary.
If it’s determined you need to restart your dataport and your integration is n2n-based, you can find instructions for restarting your dataport here.
Restarting your dataport before or in addition to opening a ticket can help expedite a resolution.
If Real-Time Merges Succeed and the Next Nightly Merge Returns Errors Again
Check whether your system is available during the merge period (i.e. Does your institution have nightly SIS maintenance during this time and the SIS is unavailable?).
Additional Recommendations
If your school consistently receives the error despite following the appropriate resolution above, please reach out to customer support.
If you are not able to replicate the error, then the error might have been caused by a period of high load, network instability, or other transient factor. If this behavior is persistent, contact customer support; we will work with your IT team and integration provider to determine next steps.
Missing Attribute Mappings
Problem Overview
This means that an attribute mapping is missing for the integration to know how to map a field value between the SIS and Coursedog (typically used when the SIS stores it as a code (i.e. LEC), but it is presented in Coursedog as a description (i.e. Lecture). This can happen when you add a new value option in the template and don’t add a corresponding mapping in the admin dashboard. You can read more on attribute mappings here.
Solution Overview
Using the error message at the top of the merge report (see above), identify the entity type, the field, and the value that is missing a mapping.
Navigate to the “Integration Attribute Mappings” tab and select the right entity type and field.
Add the missing attribute mapping as shown below and Save.
You can then run a manual merge or wait until the next nightly merge to confirm that the issue has been resolved.
No Coursedog or SIS Data Found
Name of Error
No Coursedog or SIS data found
Explanation
This message indicates there is no data in the SIS to retrieve for a given term. That said, the reason for there not being any data to retrieve depends on whether or not data is expected (See “How to Resolve” below).
How to Resolve
Check to see if there truly isn’t any data to retrieve for the given term. If that is the case, then data isn’t expected, and you can either ignore the error or resolve it in your SIS.
If data IS expected, then you should reach out to Coursedog support as it is likely one of the following:
There was a connection error, and the merge failed to retrieve data from the SIS.
There was a failure in transformation or processing in the partner integration layer (i.e. N2N) that led to the merge not receiving any data from the SIS.
Numeric or Value Error for Section Merges
Name of Error in Merge Report
Internal error occurred : ORA-06502: PL/SQL: numeric or value error: character to number conversion errorORA-06512: at line 1
Explanation
This error could be the result of one of two potential causes.
Cause 1
If your institution's SIS integrates via N2N – and you’ve recently installed/updated new scripts – then if you receive this error, it is most likely caused by the beautify process N2N uses in Illuminate for the Input Transformation.
If you use N2N, we should look into whether additional spaces were added during N2N’s beautify step. The Coursedog Data Engineering (DE) team should be able to view the API details in Illuminate to see if there are additional spaces within the Input Transformation (your DE might need to paste the XSLT into an editor in order to see these extra spaces).
Input Transformation / XSLT
Cause 2
Any institution could receive the same message by sending invalid codes/values in the post API (e.g. campus:"my special campus" vs campus:"msc").
How to Resolve
Cause 1
Reach out to Coursedog so your DE can confirm the beautify process is indeed the cause.
Once confirmed, your DE will open a ticket with N2N in order to get this resolved.
Cause 2
If you don’t use N2N and/or your DE determines the beautify step is NOT the cause of your error, you and your DE will need to investigate further to figure out which field is not being sent correctly.
Code Field Not Updating
Name of Error in Merge Report
You won’t see an error for this.
Problem Overview
Even though the subject and/or course number were updated, the code – which is a combination of those two values – didn’t update.
Explanation
This could mean one of two possible things:
Your SIS might require you to update the code on your own.
“Code” is in the merge field exceptions as “Always Coursedog”, but you changed the subject and/or course number in your SIS first.
Halted: Change Threshold Exceeded
Name of Error in Merge Report
# entities have updates, which is above the change threshold of 100.
Problem Overview
You will see this error if your nightly integration attempts to post updates for more than 100 entities.
Explanation
We have set a threshold of 100 to prevent unintentional large scale data loss/change in the SIS.
If you have confirmed you do indeed need to post updates to more than 100 entities, you can bypass the threshold when running a manual merge at Admin > Execute Merge.